ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "M.A.Dunphy" <madun...@bigfoot.com>
Subject RE: Problem with DTD in ant1.3b3
Date Wed, 07 Mar 2001 10:45:01 GMT
Hi Stefan,

With the problem of the antstructure task in Ant 1.3, is it valid to use a
DTD file generated from ant 1.3 beta3? Note that in that beta release the
generated DTD had problems as described below, in particular, the +, -, =
symbols. If I replaced these with the words plus, minus, equals the beta3
DTD file was file?

Or has the problem in the 1.3 release been fixed in a recent nightly build
that I could use?

Thanks

Mick

-----Original Message-----
From: M.A.Dunphy [mailto:madunphy@bigfoot.com]
Sent: 26 February 2001 14:31
To: 'ant-user@jakarta.apache.org'
Subject: RE: Problem with DTD in ant1.3b3


after looking at this further, it appears to be in the section:

<!ELEMENT entry EMPTY>
<!ATTLIST entry
          id ID #IMPLIED
          operation (+ | - | = | now | never) #IMPLIED
          default CDATA #IMPLIED
          key CDATA #IMPLIED
          type (int | date | string) #IMPLIED
          pattern CDATA #IMPLIED
          value CDATA #IMPLIED>

Thanks

Mick

PS: Just found that the TOC for the optional tasks is incomplete. It doesn't
list the depend tasks, eventhough there is a depend.html

-----Original Message-----
From: M.A.Dunphy [mailto:madunphy@bigfoot.com]
Sent: 26 February 2001 10:20
To: Ant-User (E-mail)
Subject: Problem with DTD in ant1.3b3


Hi all,

I've just downloaded the 1.3b3 release, and used the antstructure task to
generate the DTD file. When I run ant on our build file it fails saying:

C:\...\build.xml:714: Name tokens must not start with "+" characters.

This appears to be a problem with the generated DTD. Anybody know what the
problem is and the solution?

Thanks

Mick

Mime
View raw message