ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "M.A.Dunphy" <madun...@bigfoot.com>
Subject potential bug with antstructure?
Date Mon, 05 Mar 2001 10:33:46 GMT
Before I raise this as a bug, 

Has anybody else had problems with the antstructure task in 1.3.

When I run it I get the following error:

C:\TEMP\testing>ant -buildfile AntStructure.xml
Buildfile: AntStructure.xml

main:

BUILD FAILED

java.lang.NoClassDefFoundError: org/apache/xalan/xslt/XSLTInputSource
        at java.lang.Class.getMethods0(Native Method)
        at java.lang.Class.getMethods(Class.java:742)
        at
org.apache.tools.ant.IntrospectionHelper.<init>(IntrospectionHelper.java:115
)
        at
org.apache.tools.ant.IntrospectionHelper.getHelper(IntrospectionHelper.java:
208)
        at
org.apache.tools.ant.taskdefs.AntStructure.printElementDecl(AntStructure.jav
a:195)
        at
org.apache.tools.ant.taskdefs.AntStructure.printElementDecl(AntStructure.jav
a:287)
        at
org.apache.tools.ant.taskdefs.AntStructure.execute(AntStructure.java:129)
        at org.apache.tools.ant.Target.execute(Target.java:153)
        at org.apache.tools.ant.Project.runTarget(Project.java:898)
        at org.apache.tools.ant.Project.executeTarget(Project.java:536)
        at org.apache.tools.ant.Project.executeTargets(Project.java:510)
        at org.apache.tools.ant.Main.runBuild(Main.java:421)
        at org.apache.tools.ant.Main.main(Main.java:149)

Thanks

Mick

Mime
View raw message