ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nathan.chand...@orange.co.uk
Subject <java> task 1.2 to 1.3
Date Fri, 30 Mar 2001 10:09:20 GMT

Hi

Just switched to Ant 1.3 and a <java> task that worked fine previously is now
failing. build.xml portion as follows:

  <target name="do-java">
    <java classname="JFlex.Main" fork="yes" dir="${build.src}/org/path/to/dir/">
      <arg value="-q" />
      <arg value="my.lex" />
      <classpath>
        <pathelement location="${contrib.dir}/compile/JFlex.jar" />
      </classpath>
    </java>
  </target>

With 1.2 when I run ANT I get output

do-java:
     [java]   Warning : blah blah

then everything works OK

However, with 1.3 I just get

do-java:
     [java]  Java Result: -1

with no errors or anything.

any help greatly appreciated.



*******************************************************************************
Important. This E-mail is intended for the above named person and may be
confidential and/or legally privileged. If this has come to you in error you
must take no action based on it, nor must you copy or show it to anyone; please
inform the sender immediately.
*******************************************************************************

Mime
View raw message