ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From De Wolf Olivier <Olivier.De.W...@capco.com>
Subject RE: environment
Date Fri, 23 Mar 2001 15:47:28 GMT

I have exactly the same problem when I run ant from cygwin. No problems when
a run it from the dos.
I think that it is because cygwin does not "deliver" the windows environment
variables to ant (but I'm not sure).


-----Original Message-----
List:     ant-user
Subject:  environment
From:     "b. thym" <benny@thym.de>
Date:     2001-03-21 11:32:43Hello together,

under w2k with ant1.3 i have the following error, if i want to get the
tomcat.home from the environment like this:

  <property environment="env" />
  <property name="deploy.home"
value="${env.TOMCAT_HOME}/webapps/${app.name}"/>


And here the error:

java.lang.String.IndexOutOfBoundsException: String index out of range: -1
    at java.lang.String.substring(String.java:1503)
    at
org.apache.tools.ant.taskdefs.Property.loadEnvironment(Property.java:248)



Does anybody know this problem?

bye
benjamin thym

************************************************************************
The information in this email is confidential and is intended solely
for the addressee(s).
Access to this email by anyone else is unauthorised. If you are not
an intended recipient, you must not read, use or disseminate the
information contained in the email.
Any views expressed in this message are those of the individual sender,
except where the sender specifically states them to be the views of
The Capital Markets Company.

http://www.capco.com
***********************************************************************


Mime
View raw message