ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeffrey Porter <j...@metadyne.uk.com>
Subject ANT JavaC problem. inner class not found.
Date Fri, 23 Mar 2001 11:08:19 GMT


Heres the problem....

I compile my 'API' in task One.

I compile my 'test suites' in task Two.

Task two complains that it cannot find an inner class of one of the files
complied in task one.
I've check that it is there between the two tasks, and it is. (preformed a
javap on the inner & outer class)

If I run the script a second time, it works fine. (keeping the classes built
from the first run)
I've tried all the compliers (Jikes, Modern, Classic).
Both test output classes to different directory, both these are on the
classpath.
If I set the script to complie all the classes except the class that gives me
problems, then
have another task to complie that last file, it still fails.

Summary......


I've looked through the log produced by Ant, and it seems that it does not
load my inner class.
It loads other inner classes from jars & from disk.
It is a private inner class, but I can't see why that is a problem.


Someone please help.

Jeff.




--
.........if in doubt, get a hammock



Mime
View raw message