ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Monsorno <monso...@exolution.de>
Subject Re: Problems with CLASSPATH
Date Wed, 14 Mar 2001 11:44:54 GMT
Got the same problem, but my resulting classpath is the environmental
CLASSPATH + the one I specified.

Isn't it possible to make ant NOT use the CLASSPATH settings of the 
environment?

Larry Yates wrote:
> 
> Hi,
> I'm trying to compile with a classpath that I define at runtime, but the
> compile uses
> the environment CLASSPATH. The "Compilation args" show that the PATH I
> define is not used.
> 
> What am I doing wrong?
> 
> Here is the build.xml:
> <project name="Ecom" default="compile" basedir=".">
>    <property name="app.name" value="release2"/>
>    <property name="deploy.home"
> value="/test/applications/demo/${app.name}"/>
>    <property name="classes" value="${deploy.home}/servletclasses"/>
> 
>    <path id="project.class.path">
>      <fileset dir="/">
>        <include name="${java.home}/lib/classes.zip,
>                       ${java.home}/lib/servletclasses.zip,
>                       ${java.home}/lib/tsmp.jar,
>                       ${classes},
>                       ${deploy.home}/lib/xerces.jar,
>                       ${deploy.home}/lib/xalan.jar" />
>      </fileset>
>    </path>
> 
>    <target name="compile">
>       <rmic  base="${deploy.home}/servletclasses"
>              includes="**/*Impl.class"
>            <classpath refid="project.class.path" />
>       </rmic>
>    </target>
> </project>
> 
> Thanks for any and all help!
> -Larry

-- 
Martin Monsorno
mailto:Martin.Monsorno@exolution.de

Mime
View raw message