ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David J Iannucci <...@myriad.com>
Subject Re: mapper type="regexp" doesn't work (was: Can't find <apply> task)
Date Wed, 07 Mar 2001 23:52:03 GMT
Glenn McAllister wrote:
> 
> David J Iannucci wrote:
> 
>> Look, I've read the docs.  And I realize you all can't
>> see precisely what I'm doing, but I don't think I've
>> missed anything major here.  Why is this not working?
> 
> Well, do you have the regexp jars in your classpath?
> Glenn

Thanks for the response, Glenn.  Um, sure... well, what do you
mean "regexp jars"?  It isn't necessary to have just the regexp
stuff in *separate* jars, is it?  As I mentioned in my last message,
I tried putting the regexp classes into my classpath, and also
tried putting ant.jar, which contains these classes, into my
classpath, and ant was seemingly unable to find the classes in
either location.

So again, the question remains: what's missing here?

Incidentally, in my last message there was a mistake.  I meant
to say that I had tried adding the flags

-Dant.regexp.matcherimpl=org.apache.tools.ant.util.regexp.JakartaRegexpMatcher
-Dant.regexp.matcherimpl=org.apache.tools.ant.util.regexp.JakartaOroMatcher

to my ant run as well, and that these hadn't worked, either.

Thanks,
Dave

Mime
View raw message