ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David J Iannucci <...@myriad.com>
Subject mapper type="regexp" doesn't work (was: Can't find <apply> task)
Date Wed, 07 Mar 2001 22:14:45 GMT
> In what way does it not exist for you? Do you get an error if you try to use
> it, or have you tried to find it inside the jar?

Thanks for the help.  I'm beyond that problem now :-)  The reason
ant was telling me it couldn't find the task, apparently, was because
I only tried to _run_ under Ant 1.2, but downloaded version 1.3 and
tar tv'ed, jar tv'ed, and grepped my way through it looking for
Apply.class and couldn't find it.  Anyway, now that I'm actually
running 1.3, I've got <apply>.

> It physical name is org.apache.tools.ant.taskdefs.Transform if that may
> be your problem?

Well, gee, that's intuitive :-)

----

Now I have a different problem.  I can't get <mapper> to work right.
Inside my <apply> task, I've got:

   <mapper type="regexp" from="(.*)\.p[lmhp]$$" to="\1.html" />

but when I try to run ant, now it tells me:

   No supported regular expression matcher found

I've got both classes

   org/apache/tools/ant/util/regexp/JakartaOroMatcher.class
   org/apache/tools/ant/util/regexp/JakartaRegexpMatcher.class

in my $CLASSPATH (I'm running Solaris 8).  I've even tried it
both with these classes out in the open filesystem and jarred up
inside ant.jar, and ant doesn't seem able to find them.  I also
tried

   ant
-Dant.regexp.matcherimpl=org.apache.tools.ant.util.regexp.RegexpMatcher

with no luck.  Look, I've read the docs.  And I realize you all can't
see
precisely what I'm doing, but I don't think I've missed anything major
here.
Why is this not working?

Thanks in advance,
Dave

Mime
View raw message