ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <dona...@apache.org>
Subject Re: mapper type="regexp" doesn't work (was: Can't find <apply> task)
Date Thu, 08 Mar 2001 00:14:10 GMT
At 04:52  7/3/01 -0700, David J Iannucci wrote:
>Thanks for the response, Glenn.  Um, sure... well, what do you
>mean "regexp jars"?  It isn't necessary to have just the regexp
>stuff in *separate* jars, is it?  As I mentioned in my last message,
>I tried putting the regexp classes into my classpath, and also
>tried putting ant.jar, which contains these classes, into my
>classpath, and ant was seemingly unable to find the classes in
>either location.

The regexp classes in ant rely on external regex libraries (namely Apache
oro, gnu.regexp and I believe Apache regexp). You need one of these for the
regexp mappers to work ;) 
Cheers,

Pete

*-----------------------------------------------------*
| "Faced with the choice between changing one's mind, |
| and proving that there is no need to do so - almost |
| everyone gets busy on the proof."                   |
|              - John Kenneth Galbraith               |
*-----------------------------------------------------*


Mime
View raw message