ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Denis Balazuc" <denis.bala...@trader.com>
Subject Re : delete not working
Date Mon, 26 Mar 2001 16:57:59 GMT
 Hi everyone,

 I'm experiencing this myself on J2EE.jar which is used in the classpath for
 a previous compilation step.
 However, delete (for the entire directory in which j2ee.jar sits) doesn't
 seem to do its job, even though there is no more compilation in progress.
 Funnily enough, However, it is the only file that is not deleted...
 Note that this JAR file is not included in Ant's classpath...

 So any clue of which process may "hold" this file ?

> ----- Original Message -----
> From: "Kuriti, Mohan" <KuritiM@trizetto.com>
> To: <ant-user@jakarta.apache.org>
> Sent: Friday, March 23, 2001 16:56
> Subject: delete not working
>
>
> > > Hi Gurus,
> >  > I am using the following target in my xml file.
> >  The files are not getting deleted.
> >   <target name="clean1" depends="dist">
> >  <!-- Delete the ${build} and ${dist} directory trees -->
> >  <delete dir="${src}/${build}"/> > <!--delete dir="${dist}" /-->
> >  </target> > > Can anybody help please? I am using ant1.2 .
> >  Thanks in advance
> >  Mohan
> >
> > Are all the files not being deleted? Some of them? What do you see with
> the
> > -verbose or -debug flags?
> > Glenn
> >
> >
> > I've seen this before and it was because something else still had a
handle
> > to one or more of the files you are trying to delete. Close all apps
> > (restart if necessary) and try it again. I've found TextPad (an editor
for
> > Windows) will hold on to files after you've closed them.
> >  It's worth a shot.
> > Andy
> > ****************************
> > Andrew Goodnough Dana Commercial Credit Programmer
> > I am not getting any files deleted. The target is not getting executed
as
> > shown from the output to the console.
> > Can anybody give more pointers?
> > Mohan
> >
> >
> >
> >
>


Mime
View raw message