ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Stillwell <Chris.Stillw...@wcom.com>
Subject RE: rmic and stubversion=1.2
Date Wed, 14 Mar 2001 16:42:08 GMT
Thanks, with using -verbose I was able to figure it out.  The class I'm
running rmic on is an inner class, so it is really out in the directory as
ngn.databus.admin.JiniFinder$MyEventListener not
ngn.databus.admin.JiniFinder.MyEventListener even though programmatically it
is referred to in its dot separated form.  I just changed my target as
follows an it seems to work:
  <target name="rmic" depends="prepare" description="rmic">
    <rmic classname="ngn.databus.admin.JiniFinder$$MyEventListener"
          base="${classes}"
	  classpath="${dest}:${jini_libs}"
	  stubversion="1.2"/>
  </target>

Chris


-----Original Message-----
From: Stefan Bodewig [mailto:bodewig@apache.org]
Sent: Wednesday, March 14, 2001 9:55 AM
To: ant-user@jakarta.apache.org
Subject: Re: rmic and stubversion=1.2


Chris Stillwell <Chris.Stillwell@wcom.com> wrote:

> Yes, that's what I'm saying.

Could you please run ant -verbose? It should say something like

XYZ.class added as XYZ_Stub.class doesn't exist.

or

XYZ.class added as XYZ_Stub.class is outdated.

And it should not be talking about _Skel files with stubversion="1.2".

Stefan


Mime
View raw message