ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@cortexebusiness.com.au>
Subject RE: creating empty jars ...
Date Fri, 16 Feb 2001 03:02:05 GMT
Can you run it with ant -debug to see what ant is doing and why it might be
deciding to do nothing.

Conor

> -----Original Message-----
> From: G.L. Grobe [mailto:gary@grobe.org]
> Sent: Friday, 16 February 2001 13:46
> To: ant-user@jakarta.apache.org
> Subject: Re: creating empty jars ...
>
>
> I don't put webdir under WEB-INF because that's not the way web apps are
> deployed according to the 2.2 servlet specs. I don't believe you
> can access
> anything directly under WEB-INF, which is why I place jars, gifs, etc
> outside of this dir, just static content stuff.
>
> Besides, it should work no matter what directory name I give it. Shouldn't
> two consecutive jars work?
>
> My directory structure looks like this.
>
> +build.xml
> +WEB-INF
>  |     + classes
> +conf
> +web
>        + images
>        + jars
>
> ----- Original Message -----
> From: <Steve.Deridder@Level3.com>
> To: <ant-user@jakarta.apache.org>
> Sent: Thursday, February 15, 2001 8:35 PM
> Subject: RE: creating empty jars ...
>
>
> > First of all where is basedir?  Why not copy the web dir to be under
> > ${web-inf} and then run.  Trying  to eliminate this.
> >
> >       <!-- IT WILL NOT BUILD THIS JAR-->
> >       <jar jarfile="web/jars/images.jar"
> >          basedir="web"
> >          includes="images/**"
> >       />
> >
> > TO
> >
> >       <!-- IT WILL BUILD THIS JAR  ;)-->
> >       <jar jarfile="web/jars/images.jar"
> >          basedir="${web-inf}/web"
> >          includes="images/**"
> >       />
> >
> >
> > -----Original Message-----
> > From: G.L. Grobe [mailto:gary@grobe.org]
> > Sent: Thursday, February 15, 2001 7:24 PM
> > To: ant-user@jakarta.apache.org
> > Subject: Re: creating empty jars ...
> >
> >
> > This is nuts, ant is not executing this jar file. I've got both
> jars being
> > created in a target and it only builds one jar, and not the other no
> matter
> > what order their placed in. I've been using ant for over a year now, but
> it
> > will not build this one simple jar. The files are there, the dirs are
> there
> > ... !
> >
> > Any known issues I'm not aware of here?
> >
> >  <target name="dist" depends="compile">
> >       <copy file="./conf/web.xml" tofile="${web-inf}/web.xml" />
> >
> >       <!-- IT WILL NOT BUILD THIS JAR-->
> >       <jar jarfile="web/jars/images.jar"
> >          basedir="web"
> >          includes="images/**"
> >       />
> >
> >       <jar jarfile="web/jars/builder.jar"
> >          basedir="${web-inf}/classes"
> >          includes="${nq}/applets/builder/**"
> >       />
> >      </target>
> >
> > > This is what I use for creating a webcontent jar.  (Changed for your
> > > content)
> > >
> > > <property name="images" value="web/images" />
> > >
> > >  <jar jarfile="web/jar/images.jar"
> > >        basedir="${images}"
> > >        includes="**"
> > >   />
> > >
> > > OR
> > >
> > > If you want the images dir in the jar (images/*.gif) change to:
> > >
> > > <property name="images" value="web" />
> > > <jar jarfile="web/jar/images.jar"
> > >        basedir="${images}"
> > >        includes="images/**"
> > >   />
> > >
> > >
> > > HTH
> > > steve
> > >
> >
>
>


Mime
View raw message