ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@cortexebusiness.com.au>
Subject RE: problem with ejbjar tag, please help
Date Tue, 13 Feb 2001 04:58:41 GMT
Saurabh,

I think you may need to check your classpath, ${descriptorbuild.classpath},
to make sure the necessary Weblogic classes are present. In particular
weblogicaux.jar is required. Can you run Ant with -debug to see what are the
classpaths being used when calling weblogic.ejbc.

A couple of points:
Please do not post in HTML in future.
No need to repeat your emails. It won't, in general, get you an answer any
faster.

Cheers
Conor

-----Original Message-----
From: Saurabh Agarwal [mailto:saurabh.agarwal@wipro.com]
Sent: Tuesday, 13 February 2001 15:34
To: ant-user@jakarta.apache.org
Subject: problem with ejbjar tag, please help


sir/madam,
 I'm using this ant tool for ejbc and deployment of bean.
 i'm using weblogic 5.1, jdk1.2.2

<target name="ejbjar1" depends="move1" >
     <ejbjar srcdir="${build.classes}"  descriptordir="${desti}"
 basejarname="refcnt">
       <weblogic destdir="${deploymentjars.dir}"
 classpath="${descriptorbuild.classpath}"/>
       <include name="**/*ejb-jar.xml"/>
       <exclude name="**/*weblogic*.xml"/>
     </ejbjar>
 </target>

this is a piece of code which i'v written.
 but it gives the error:   java.lang.NoClassDefFoundError:
 com/sun/java/util/collection/List


srcdir:       all the class files
 descriptordir:    path for Xml files
 destdir:    ??????   (i'v doubts that what should be the dir?????)
 classpath:    classpath of class files required to build jar

I'm stuck up here so please send me a quick reply. It's a workstopper!!!

regards
 saurabh

.....................................................
Wipro Technologies
 Systems Engineer
 Tower 4, 4th Floor, B wing,
 #72, Keonics Electronics City
 Hosur Main Road., Bangalore - 561 229
 PH:  8520408 Extn:4485
 Mail: saurabh.agarwal@wipro.com


Mime
View raw message