ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@cortexebusiness.com.au>
Subject RE: Ant not using the correct compiler
Date Thu, 22 Feb 2001 01:56:27 GMT
Dave,

Which version of Ant?
Are there any instances of java.exe in winnt\system32?
What is JAVA_HOME set to? Is it the same one as in your path.

What does "ant -debug" say at the top (version of Java detected, etc).

Conor

--
Conor MacNeill
conor@cortexebusiness.com.au
Cortex eBusiness 
http://www.cortexebusiness.com.au

> -----Original Message-----
> From: Dave Knox [mailto:dknox@iona.com]
> Sent: Thursday, 22 February 2001 12:12
> To: ant-user@jakarta.apache.org
> Subject: Ant not using the correct compiler
> 
> 
> I'm stuck trying to get ant to use JDK1.3.
> 
> I've used the <property name="build.compiler" value="modern">
> to try to force ant to use JDK1.3. I turned on verbose in the 
> javac task and
> the rt.jar from jdk1.2.2 is still getting sucked in. This is a 
> real stinger
> since I'm using a EJB1.1 compliant app server that demands 1.3. 
> I've checked
> $JAVA_HOME, it is set properly. The only JDK in my PATH is JDK1.3. I'm on
> Windows NT4 sp6.  How do I get ant to use JDK1.3? I saw a note on the FAQ
> that said this was fixed last summer??
> 
> David Knox
> Iona Technologies Global Services
> v: 303.748.8906
> fax2email: 435.508.9145
> fax: 303.979.7861
> text paging: 3037488906@mobile.att.net
> 
> 

Mime
View raw message