ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Hodgetts <pa...@zzyzxtek.com>
Subject Problems Building Ant
Date Wed, 07 Feb 2001 03:27:55 GMT
I just wiped out my Ant directory and checked out all the latest
from CVS.  So as far as I can tell, I have nothing except what's
currently checked in.

When I bootstrap, I get a few errors:

* The first is when it's trying to build the JUnit optional
package.  The class AggregateTransformer is referencing the
class javax.xml.transform.Transformer.  This doesn't seem to
be in JAXP release 1.0.1.  I found it in the EA release of
JAXP 1.1, in the crimson.jar, and in the Xalan release.  I'm
assuming this just needs the XSLT stuff, so the only real
issue then is to update the docs to mention this.  This seems
to be new in the latest sources, since I've built without
Xalan before.

* Once I fix the above error, I get down to almost the end of
the build, and it's trying to copy files from src/bin in the
main target.  I don't see any src/bin in the archives.  Am I
missing something?  Is the build.xml wrong?  If I just add a
src/bin directory, then it gets past this, but...

* The next error is when it tries to copy junit.jar from the
build/ant/lib/optional .  I assume this is missing because
the newly created src/bin directory is empty, although it
seems these files exist in the lib directory, so shouldn't
they be copied from there???

I know I'm reporting problems without offering patches, but
I haven't had a chance to dig into things yet, and I'm still
a bit confused with all the recent build changes so I don't
feel up to speed on anything at this point.

Thanks,
Paul


Mime
View raw message