ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <dona...@apache.org>
Subject Re: [BUG] Forking doesn't work with <java>
Date Wed, 28 Feb 2001 00:16:10 GMT
At 10:30  27/2/01 -0500, philippe.lavoie@cactus.ca wrote:
>(Not sure to which list it belongs, for that matter I don't even know if
>this list is active)

This list is strangely inactive at this time ;) but this is right place.
(well ant-user is).

>Often I get the dreaded build fail error when I use fork="yes" in the <java>
>task.
>
>I never saw this behavior with the ant used inside Cocoon 1.8.2 however I
>have now updated to ant 1.2.2 

Try updating to latest ant1.3 beta version.

>If I turn off forking, then the build process doesn't work proeperly. (I'm
>using stylebook to generated my docs and it absolutely needs a forked java
>otherwise it exits the java used by ant). 

Try looking at the stylebook task ;)

>/home/plavoie/project/vbc/build.xml:185: java.io.IOException: java: cannot
>execute
>java.io.IOException: java: cannot execute

It looks like it can not find the java executable. Whats your PATH ? set to
and also ANT_HOME ?

Cheers,

Pete

*-----------------------------------------------------*
| "Faced with the choice between changing one's mind, |
| and proving that there is no need to do so - almost |
| everyone gets busy on the proof."                   |
|              - John Kenneth Galbraith               |
*-----------------------------------------------------*


Mime
View raw message