ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "George McKInney" <geo...@tantalus.com>
Subject RE: 1.3 beta and forking java
Date Thu, 08 Feb 2001 15:54:53 GMT
> -----Original Message-----
> From: Mike Pedersen [mailto:michael.pedersen@oracle.com]
> Sent: Wednesday, February 07, 2001 4:58 PM
> To: ant-user@jakarta.apache.org
> Subject: 1.3 beta and forking java
>
<snip>
> BUILD FAILED
>
> /private/private2/javabuild/newbuild/marlin/marlin.xml:47:
> Java returned: -1
>
</snip>

We had a POSSIBLY similar problem. The symptoms included the "Java
returned: -1"

It seemed to appear when we did a fork OR AN exec/execon AND only when the
directory we were working in was NOT the one from which we started the
build. We were running a sub-build to do code translation using Oracle's
sqlj classes. Some testing showed that this only happened on our Solaris
machines and happened with ANY executable ( we tested on the Solaris side
using ls; on NT with a simple .bat file)

The workaround that we use now (on both Solaris and NT) is to create another
<build>.xml file in the start-up directory, and have it simply do the task
that has problems.

Don't know what the problem is, or why this method dodges it, and I'd really
like to hear an explanation (or see a fix :-).



George McKinney, Developer
tantalus communications inc.
500-1122 Mainland Street
Vancouver, BC, Canada V6B 5L1
george@tantalus.com

Direct  604.726.6753
Main    604.609.0700
Fax     604.609.0705
www.tantalus.com
"When eBusiness experience counts."




Mime
View raw message