ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@cortexebusiness.com.au>
Subject Re: ejbjar task with WebLogic 6.0
Date Tue, 20 Feb 2001 12:53:34 GMT
Maurice,

Well -noexit is undocumented but has been supported at least since 4.5.1.
In the 4.5.1 based ejbc task, it is critical that the ejbc command not
cause the VM that it is running in to exit.

Anyway, it is not currently required for ejbjar, so I will remove it now.

Now to your problem, you seem to have specified a classpath which evaluates
to nothing, confusing the java invocation

java -classpath  weblogic.ejbc -noexit

In this case the -noexit parameter is being passed to the VM rather than
the weblogic class. Can you please look at your classpath and see what is
happening there.

Conor




----- Original Message -----
From: "Mills, Maurice" <Maurice_Mills@CINFIN.com>
To: "Ant-User (E-mail)" <ant-user@jakarta.apache.org>
Sent: Tuesday, February 20, 2001 7:29 AM
Subject: ejbjar task with WebLogic 6.0


> I am trying to use the EjbJar task with Weblogic 6.0.  When it get to the
> step in the build, I get the following output:
>
>      [ejbc] Forking java -classpath  weblogic.ejbc -noexit
> C:\workarea\TestApp\l
> ib\Quote-generic.jar C:\workarea\TestApp\lib\Quote.jar
> Execute:Java13CommandLauncher: java -classpath  weblogic.ejbc -noexit
> C:\workare
> a\TestApp\lib\Quote-generic.jar C:\workarea\TestApp\lib\Quote.jar
>      [ejbc] Unrecognized option: -noexit
>      [ejbc] Could not create the Java virtual machine.
>      [ejbc] Java Result: 1
>
> Evidently -noexit is not a valid option.  I have tried the command line
> printed above and it gives me the same error.  If I remove the -noexit
from
> the command line, it works fine.
>
> I have looked into the code for this task and it appears that there is no
> way to turn this off.  Does anyone have any suggestions?
>
> Ant: 1.3 Beta2
> WebLogic: 6.0
> OS: W2K
> JDK: 1.3
>
> Thanks,
> Maury
>


Mime
View raw message