ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "G.L. Grobe" <g...@grobe.org>
Subject creating empty jars ...
Date Thu, 15 Feb 2001 04:14:19 GMT
I get the following error below when trying to build an images.jar file within a 2.2 servlet
web applications directory structure. The images directory is full of gifs and I'm not using
any recursion, just all files within it. I'm sure the basedir is pointing in the correct place.
I've tried many different basedir and includes but still can't get it right. The builder.jar
works fine.

dist:
      [jar] Building jar: /u/build/web/jars/builder.jar
      [jar] Note: creating empty jar archive /u/build/web/jars/images.jar
      [jar] Building jar: /u/build/web/jars/images.jar

BUILD SUCCESSFUL

my directory structure looks like this.

+build.xml
+WEB-INF
 |     + classes
+conf
+web
       + images
       + jars

--------- SNIP -------------------------------------------------
   <property name="nq" value="com/neuroquest" />
   <property name="images" value="web/images" />
--------- SNIP -------------------------------------------------

 <target name="dist" depends="compile">
      <copy file="./conf/web.xml" tofile="${web-inf}/web.xml" />

      <jar jarfile="web/jars/builder.jar" basedir="WEB-INF/classes"
         includes="${nq}/applets/builder/**"
      />

      <jar jarfile="web/jars/images.jar" basedir="${images}"
         includes="/*"
      />

   </target>
--------- SNIP -------------------------------------------------

Mime
View raw message