ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ori Burstein" <oburs...@cisco.com>
Subject Re: Exec fails , please advise
Date Wed, 21 Feb 2001 13:42:18 GMT
Thanks  Rey and Conor.
the <arg line= " ........ > just fixed it !
(and I hope that Ant 2.0 is on its way :-)

Thanks again

Ori

----- Original Message -----
From: "Sylvain Rey" <ramsey@bluedot.com>
To: <ant-user@jakarta.apache.org>
Sent: Wednesday, February 21, 2001 3:26 PM
Subject: RE: Exec fails , please advise


> It seems you use <arg value="arg1 arg2"> instead of <arg line="arg1
arg2">.
> Or you could put several "arg value"
>
> Sylvain
>
> > From: Ori Burstein [mailto:oburstei@cisco.com]
> > The Genic.bat is on the path.
> > when I run the exact line through the command line it works out fine.
> > Thnaks
> >
> > Ori
> >
> > ----- Original Message -----
> > From: "Conor MacNeill" <conor@cortexebusiness.com.au>
> > To: <ant-user@jakarta.apache.org>
> > Sent: Wednesday, February 21, 2001 3:15 PM
> > Subject: Re: Exec fails , please advise
> >
> >
> > > Ori,
> > >
> > > You may need to provide the full path to Genic.bat or have it in your
> > path.
> > > Can you try that?
> > >
> > > BTW, can you send me a copy of Ant 2.0. I have been wondering
> > how it would
> > > turn out. :-)
> > > Please. I'm just kidding.
> > >
> > > Conor
> > >
> > > ----- Original Message -----
> > > From: "Ori Burstein" <oburstei@cisco.com>
> > > To: <ant-user@jakarta.apache.org>
> > > Sent: Wednesday, February 21, 2001 11:40 PM
> > > Subject: Exec fails , please advise
> > >
> > >
> > > Hi,
> > > I'm using Ant 2.0 on windows NT.
> > >
> > > When I try to use the follwing code :
> > > <exec executable="Genic.bat -d ${classDst} ejb-jar.xml" >
> > >
> > >
> > > I get the error listed below.
> > >
> > > Any Idea on what should I do ? I tried using the arg tag:
> > >
> > > <arg value="-d ${classDst} ejb-jar.xml" />
> > >
> > > But the executable didn't get it right ( got it with the " " , which
> > caused
> > > it not to run)
> > >
> > >
> > > Thnx ,
> > > Ori
> > >
> > >
> > >
> > > BUILD FAILED
> > >
> > > X:\enm\JavaApp\build.xml:31: Execute failed: java.io.IOException:
> > CreatePro
> > > cess: "Genic.bat -d X:\enm_qos\JavaApp/buildDst/classes ejb-jar.xml"
> > > error=2
> > > java.io.IOException: CreateProcess: "Genic.bat -d
> > X:\enm/buildDst/classes
> > > ejb-jar.xml" e
> > > rror=2
> > >         at java.lang.Win32Process.create(Native Method)
> > >         at java.lang.Win32Process.<init>(Win32Process.java:66)
> > >         at java.lang.Runtime.execInternal(Native Method)
> > >         at java.lang.Runtime.exec(Runtime.java:551)
> > >         at java.lang.reflect.Method.invoke(Native Method)
> > >         at
> > >
> > org.apache.tools.ant.taskdefs.Execute$Java13CommandLauncher.exec(E
> > xecute.ja
> > > va:390)
> > >         at
> > org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:247)
> > >         at
> > > org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:213)
> > >         at
> > > org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:154)
> > >         at org.apache.tools.ant.Target.execute(Target.java:142)
> > >         at org.apache.tools.ant.Project.runTarget(Project.java:818)
> > >         at
org.apache.tools.ant.Project.executeTarget(Project.java:532)
> > >         at
org.apache.tools.ant.Project.executeTargets(Project.java:506)
> > >         at org.apache.tools.ant.Main.runBuild(Main.java:420)
> > >         at org.apache.tools.ant.Main.main(Main.java:149)
> > >
> > > Total time: 3 seconds
> > >
> > >
> > >
> > >
> > >
> > >
>
>


Mime
View raw message