ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vincent Kennedy" <vincent_kenn...@hotmail.com>
Subject Ant newbie - Compiler Problems
Date Wed, 24 Jan 2001 11:31:23 GMT
I apologise in advance if this problem is stupidly simple, but I am a newcomer to Ant.
I am running Ant 1.2, Jakarta-Tomcar 3.2.1, JDK 1.3, and all this on Win NT.
I have modified the sample build.xml file to build a simple servlet. When I run Ant I get
the following message

    [javac] File to be compiled:
    D:\Apache\jakarta-tomcat-3.2.1\webapps\Vince\src\Hello.java

    [javac] D:\Apache\jakarta-tomcat-3.2.1\webapps\Vince\src\Hello.java:67: cannot resolve
symbol
    [javac] symbol  : class ServletException  
    [javac] location: package servlet
    [javac] import javax.servlet.ServletException;
    [javac]                      ^

The complier repeats this for each import of the javax.servlet class.
It seems that it cant find the javax.servlet package.
I have tried pointing my classpath everywhere logical, and through frustration most places
illogical - Has anybody any ideas how to solve this?  I suspect that it is some sort of incompatibilty
with jdk1.3 - Either that or something so simple that you will all be laughing at me!

Any help would be appreciated.

Mime
View raw message