ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Les Hughes <leslie.hug...@rubus.com>
Subject RE: creating a label in Perforce?
Date Wed, 31 Jan 2001 10:48:45 GMT
Hi,

Ahh that'll be why :-)  Don't you just love life at the leading edge? The
task described below has been deprecated in favour of the new p4XXX commands
which you can grab either from CVS (see
http://jakarta.apache.org/site/cvsindex.html for anon access) or you can
grab a nightly build from
http://jakarta.apache.org/builds/jakarta-ant/nightly/ but I think the build
process is still a bit - ahem - broken....

<has a quick surf over to jakarta...>

Ah, temp release of 2001-01-22 contains the tasks
(http://jakarta.apache.org/builds/jakarta-ant/nightly/temp/2001-01-22/).
You'll also need oro-2.0.x from http://jakarta.apache.org/oro/index.html.
BTW The perforce stuff retro's into 1.2 just fine so you don't need to
upgrade your whole system if you don't need the 'features' of the dev
release. Just build the perforce package into it's own jar and dump in your
ANT_HOME/lib directory along with oro.jar. Oh, and make sure that the p4.exe
(or p4 for Un*x) client's on your path.....

Bye,

Les




> -----Original Message-----
> From: Dave Rhodes [mailto:daver@loudeye.com]
> Sent: 30 January 2001 23:47
> To: 'ant-user@jakarta.apache.org'
> Subject: RE: creating a label in Perforce?
> 
> 
> hi,
> I'm working with a 2 to 3 week old install of ant 1.2.
> 
> What is the link to get to this perforce tasks doc you're 
> referring to?
> 
> http://jakarta.apache.org/ant/jakarta-ant/docs/P4desc.html 
> doesn't reference
> this info.
> 
> much appreciated,
> Dave
> 
> -----Original Message-----
> From: Les Hughes [mailto:leslie.hughes@rubus.com]
> Sent: Tuesday, January 30, 2001 2:58 AM
> To: 'ant-user@jakarta.apache.org'
> Subject: RE: creating a label in Perforce?
> 
> 
> 
> Hi, 
> 
> From the docs
> p4label :- "Create a new label and set contents to reflect 
> current client
> file revisions"
> 
> Do you have the latest form CVS? The <perforce> task in 1.2 has been
> deprecated in favour of a bunch of handy p4XXX tasks; p4sync, 
> p4change,
> p4edit, p4submit, p4have and of course, p4label.
> 
> 
> Les
> 
> 
> > -----Original Message-----
> > From: Dave Rhodes [mailto:daver@loudeye.com]
> > Sent: 29 January 2001 19:26
> > To: 'ant-user@jakarta.apache.org'
> > Subject: RE: creating a label in Perforce?
> > 
> > 
> > Hi all, 
> > 
> > For some reason passing an Env Key in my exec caused ant to 
> no longer
> > connect to the perforce server.  Switching over to an Arg 
> > Value works fine.
> > 
> > And according to the ant docs, the only label functionality 
> > is "A label from
> > which to check out files.", not a label create.
> > 
> > Thanks for the suggestions. 
> > Dave
> > 
> > -----Original Message-----
> > From: Les Hughes [mailto:leslie.hughes@rubus.com]
> > Sent: Monday, January 29, 2001 2:08 AM
> > To: 'ant-user@jakarta.apache.org'
> > Subject: RE: creating a label in Perforce?
> > 
> > 
> > 
> > Hi,
> > 
> > Couple of things. Sorry if this is a bit off-ant-topic.
> > 
> > 1) The server is running? Bit of a stupid suggestion 
> > but......Following on
> > from Kiran's point, if your DNS is screwed try adding your p4 
> > server to your
> > hosts file (in system32\drivers\etc\hosts on NT) Also, try 
> explicitly
> > setting the port with p4 -p foo.bar.com:1666 (and your client 
> > and username
> > with -c and -u come to think of it)
> > 
> > 2) Not sure if you're aware but there are a bunch of perforce 
> > tasks in Ant
> > now. Grab the latest CVS and have a look in the
> > org.apache.tools.ant.taskdefs.optional.perforce package. 
> > There's no need to
> > spawn a batchfile to do your labelling, edits, syncs, submits etc.
> > 
> > 
> > Bye,
> > 
> > Les
> > 
> > 
> > > -----Original Message-----
> > > From: Kiran Muglurmath [mailto:kiran@grandcentral.com]
> > > Sent: 26 January 2001 23:37
> > > To: 'ant-user@jakarta.apache.org'
> > > Subject: RE: creating a label in Perforce?
> > > 
> > > 
> > > Looks like you cannot find "slash" in your dns server.
> > > 
> > > Can you ping slash from your command prompt? If not, try 
> > setting your
> > > perforce configuration with an ip address for your perforce 
> > > server. You can
> > > check by running "p4 client" from the command prompt. If you 
> > > are running
> > > perforce on windows, run p4win and set it from the 
> clientspec menu.
> > > 
> > > Then try running "p4 sync" from the command prompt. It should 
> > > get the latest
> > > files from the server. That means that all your client 
> > > settings are correct.
> > > You can then run p4 label to label it.
> > > 
> > > Hope that helps.
> > > 
> > > -----Original Message-----
> > > From: Dave Rhodes [mailto:daver@loudeye.com]
> > > Sent: Friday, January 26, 2001 11:27 AM
> > > To: 'ant-user@jakarta.apache.org'
> > > Subject: RE: creating a label in Perforce?
> > > 
> > > 
> > > Hi Les,
> > > I'm executing a .bat file that calls p4label.  I had a config 
> > > problem in my
> > > bat file which I fixed.  Now I'm getting a error connecting 
> > > to the perforce
> > > server.
> > > 
> > >   [exec] Perforce client error:
> > >   [exec]     Connect to server failed; check $P4PORT.
> > >   [exec]     TCP connect to slash:1666 failed.
> > >   [exec]     slash: host unknown.
> > > 
> > > The quest continues.  Any suggestions appreciated.
> > > thanks,
> > > Dave
> > > 
> > > -----Original Message-----
> > > From: Les Hughes [mailto:leslie.hughes@rubus.com]
> > > Sent: Friday, January 26, 2001 4:39 AM
> > > To: 'ant-user@jakarta.apache.org'
> > > Subject: RE: creating a label in Perforce?
> > > 
> > > 
> > > 
> > > Hi,
> > > 
> > > Are you using <p4label> or running your own thang from <exec> ?
> > > 
> > > Les
> > > 
> > > 
> > > 
> > > > -----Original Message-----
> > > > From: Dave Rhodes [mailto:daver@loudeye.com]
> > > > Sent: 25 January 2001 21:30
> > > > To: 'ant-user@jakarta.apache.org'
> > > > Subject: creating a label in Perforce?
> > > > 
> > > > 
> > > > Anyone had any luck getting Ant to create a label in Perforce?
> > > > 
> > > > Ant is taking my bat file and adding random numbers to the 
> > > > commands within.
> > > > ie:  1>>D:\ant\ANT_1_0125_125.txt  inserting the "1"
> > > > ie:  p4 label -i 0<ANT_1_0125_125.txt  inserting the "0"
> > > > 
> > > > label:
> > > >      [exec]
> > > >      [exec] D:\ant>set TOOLHOME=d:\src\mos\tools
> > > >      [exec]
> > > >      [exec] The system cannot find the path specified.
> > > >      [exec] D:\ant>IF exist LABEL.template 
> > > d:\src\mos\tools\bin\sed -e
> > > > 's/###BLDNUM###/ANT
> > > > _1_0125_125/'  LABEL.template...  1>>D:\ant\ANT_1_0125_125.txt
> > > >      [exec]
> > > >      [exec] D:\ant>c:\Program Files\PERFORCE\p4 label -i
> > > > 0<ANT_1_0125_125.txt
> > > >      [exec] The name specified is not recognized as an
> > > >      [exec] internal or external command, operable program or 
> > > > batch file.
> > > >      [exec]
> > > >      [exec] D:\ant>c:\Program Files\PERFORCE\p4 labelsync -l 
> > > > ANT_1_0125_125
> > > >      [exec]
> > > >      [exec] The name specified is not recognized as an
> > > >      [exec] internal or external command, operable program or 
> > > > batch file.
> > > >      [exec] D:\ant>IF exist ANT_1_0125_125.txt del 
> > > ANT_1_0125_125.txt
> > > > 
> > > > 
> > > > thanks,
> > > > Dave
> > > > 
> > > > 
> > > > 
> > > > 
> > > > 
> > > > 
> > > > 
> > > > 
> > > 
> > 
> 

Mime
View raw message