ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Duffey, Kevin" <KDuf...@BUYMEDIA.com>
Subject RE: vssget for VisualSourceSafe bug?
Date Thu, 04 Jan 2001 01:16:04 GMT
I should add that this is what I havE:

<vssget localPath="c:/bm/source/code-${current.build}"
        recursive="true" 
        vsspath="/Projects/${current.build}/code"
        writable="false"/>

This "should" work, but it does not..at least on the machine I tried it on.
I will attempt this again on my other machine and see if the slow speed of
that machine was the culprit. Does this look right to you? I set up the PATH
in Win2K/Environment options to point to the ss.exe dir, and I don't use any
password when I run the GUI client, so I don't supply it above. When I run
it, it does show my username in the stdout, but no password shows up (as
expected).

Lastly..what happens when it does get new files? Does it output the file
names, paths, etc to the stdout as it gets new files..or is it in a "quiet"
mode or something and basically you have to wait until its done? Also, as it
gets each file..is it done to memory then it writes out the whole list
(doubtful..that could require gobs of memory)? I assume it should create the
dirs and put the files there as it gets them. The dir is created for me, but
as I let it sit for 10 minutes, not a file was put in the dir.

Thanks again.


> -----Original Message-----
> From: KC Baltz [mailto:KBaltz@responsenetworks.com]
> Sent: Wednesday, January 03, 2001 3:48 PM
> To: 'ant-user@jakarta.apache.org'
> Subject: RE: vssget for VisualSourceSafe bug?
> 
> 
> I'm fairly certain lots of people are using it (including myself)
> successfully.  Try running ant with the -debug flag.  This 
> should spit out a
> commandline when it runs VSS.  Try pasting this commandline into your
> command prompt and see if it runs.  If it doesn't, then it's 
> not Ant's fault
> or at least you may have set up the parameters wrong.  If the 
> pasted command
> line works, then reply to the group with the snippet from 
> your build.xml of
> the <vss> task and the output it is generating with -debug.
> 
> K.C. 
> 
> > -----Original Message-----
> > From: Duffey, Kevin [mailto:KDuffey@BUYMEDIA.com]
> > Sent: Wednesday, January 03, 2001 5:43 PM
> > To: 'ant-user@jakarta.apache.org'
> > Subject: vssget for VisualSourceSafe bug?
> > 
> > 
> > Hi all,
> > 
> > I can't seem to get the vssget to work. If I use the GUI 
> > client, it works
> > fine. When I run it from ant, it shows that it is using my 
> > username, then
> > just hangs. Is there a noted bug with this feature? Is there a fix?
> > 
> > Thanks.
> > 
> 

Mime
View raw message