ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Stirling" <sstirl...@mediaone.net>
Subject RE: Compiling Ant on Linux...classic/modern javac not detected.
Date Tue, 12 Dec 2000 03:51:27 GMT
There's nothing particularly special about Linux in this regard.  RedHat
does install the Kaffe JVM and tools in /usr/bin, which you should make sure
is not screwing you up.  If you do "java -version" and get back some kaffe
version, then "rpm -e kaffe."  RedHat 7.0 installs jikes too.  I don't
recall if it installs jikes in 6.2, but that shouldn't matter if you chose
modern.

Can you post the exact errors you're getting from the build process?

Post the output of "set" too.

Scott Stirling
West Newton, MA

-----Original Message-----
From: David Elliot [mailto:jspboy@yahoo.co.uk]
Sent: Monday, December 11, 2000 1:43 AM
To: ant-user@jakarta.apache.org
Subject: Compiling Ant on Linux...classic/modern javac not detected.


Hi all,

Apologies if this is already discussed, as I can't
find an archive of this list...

Question:  When trying to build Ant on linux
(RH 6.2) the build process complains that it can't
find a classic compiler.  I have several jdks and
have now tried them all.  I have also tried setting
the compiler property to "modern" in build.xml, no
joy.  My classpath, path, java_home all look
correct, does anybody know what magic needs to be
woven for Ant to recognise a linux java compiler as
either modern or classic ??  If it would just simply
use the javac in my path (blackdown 1.3) I would be
ecstatic.

p.s. Seems odd that Ant is lining itself up for
a problem experienced by the arts community.  By
defining v1.3 as modern, will we wind up dealing
with compiler settings such as post-modern,
very-modern, ultra-modern, still-got-its-price-tag,
et all?

Thanks for any tips,

Dave Elliot


Mime
View raw message