ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Farmer" <mfarm...@bellsouth.net>
Subject Trouble getting classpath to work...
Date Fri, 08 Dec 2000 02:58:38 GMT
ARGH...
I can't figure this out. The following is a javac tag, with a classpath
defined for it.

    <javac srcdir="${src.dir}"
	       destdir="${class.dir}"

includes="${idl.class.base.package}/TRIBasicServer/*.java,${idl.class.base.p
ackage}/TRIDomain/*.java,${idl.class.base.package}/TRIEvent/*.java,${idl.cla
ss.base.package}/TRIBasicServer/*.java"
           debug="on"
           deprecation="off"
           optimize="on" >
	  <classpath>
	    <fileset dir="${lib.dir}">
		  <include name="Vbjorb.jar,Vbjapp.jar" />
		</fileset>
	  </classpath>
    </javac>

And here is the classapth argument sent to the compiler:

-classpath
C:\Projects\Java\classes;C:\bin\jakarta\ant\lib\ANT.JAR;C:\bin\jakarta\ant\l
ib\JAXP.JAR;C:\bin\jakarta\ant\lib\PARSER.JAR;C:\bin\jdk1.2.2\lib\tools.jar

SO, why isn't Vbjorb.jar and Vbjapp.jar not getting added to my classpath
parameter for the compiler? I've tried other things as well, all
unsuccessfull. For example, I tried...

	<javac ....
		classpath="${lib.dir}/Vbjorb.jar;${lib.dir}/Vbjapp.jar"
	/>

I originally tried it all with the binary distribution, then I built it
myself and I still get the same thing. Hopefully it's something really
simple and I'm just being dumb...

--michael


Mime
View raw message