ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Carlson <jcarl...@is.com>
Subject RE: zip task is not finding my files
Date Thu, 07 Dec 2000 14:09:22 GMT
I've tried every combination that I can think of.  I tried using filesets,
I've tried includes="./mydir/**", I've tried includes="./mydir/**/*".  I'm
thinking there is a bug in the zip task.

BTW, I'm using ant 1.2.

Jonathan

-----Original Message-----
From: Maxim Kur [mailto:maxim.kur@epit.com]
Sent: Wednesday, December 06, 2000 5:38 PM
To: ant-user@jakarta.apache.org
Subject: RE: zip task is not finding my files


have you tried things like
<zip zipfile="./mydir.zip"
	basedir="."
	includes="mydir/**" />

or

<zip zipfile="./mydir.zip"
	basedir="."
	includes="mydir/MyFileOne.java, mydir/MyFileTwo.java,
mydir/MyFileThree.properties" />



-----Original Message-----
From: Jonathan Carlson [mailto:jcarlson@is.com]
Sent: Wednesday, December 06, 2000 2:44 PM
To: 'ant-user'
Subject: zip task is not finding my files


I have been struggling in solitude with this for several hours so I am going
to ask you other users if you know what I am doing wrong here.
 
I have several files in ./mydir/.  What am I doing wrong that the following
doesn't create a zip file because it says it can't find any files? I tried
using filesets and everything, but nothing worked.

    <zip zipfile="./mydir.zip"
         basedir="."
         includes="./mydir/" />
 
Any ideas would be appreciated!
 
 
Jonathan Carlson,  Software Developer 
jcarlson@is.com 

Such ever was loves way: to rise, it stoops.   
     - Robert Browning 


 

Mime
View raw message