ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Murdoch" <adammurd...@yahoo.com>
Subject RE: Cannot use classic compiler, as it is not available
Date Fri, 01 Dec 2000 00:57:31 GMT

Hi,

A mismatched JVM and tools.jar can cause the problem you're seeing.

Check that your PATH is set up so that you're picking up the 'java' command
(not javac) from the same JDK that you're getting tools.jar from.  The ant
script doesn't use $JAVA_HOME to decide which 'java' to use to launch ant,
it uses $PATH instead.


> -----Original Message-----
> From: faith [mailto:faith]On Behalf Of Joe Faith
> Sent: Friday, 1 December 2000 3:11 AM
> To: ant-user@jakarta.apache.org
> Subject: Re: Cannot use classic compiler, as it is not available
>
>
> Yes, yes, and yes
>
> Joe
> (thanks for your help tho)
>
> >
> > > /home/faith/treeDev/build.xml:118: Cannot use classic compiler, as
> > > it is not available
> >
> > Hmmpf.
> >
> > /home/java/jdk1.2.2/lib/tools.jar does exist and is readable for the
> > user invoking Ant - as well as /home, /home/java, /home/java/jdk1.2.2
> > and /home/java/jdk1.2.2/lib - I guess.
> >
> > I'm as puzzled as you are.
> >
> > Does "jar tf /home/java/jdk1.2.2/lib/tools.jar" show
> > sun.tools.javac.Main?
> >
> > Stefan


__________________________________________________
Do You Yahoo!?
Talk to your friends online with Yahoo! Messenger.
http://im.yahoo.com

Mime
View raw message