ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kevin Mukhar <>
Subject Re: Please help - "Cannot use classic compiler"
Date Wed, 20 Dec 2000 14:54:58 GMT
> Jacob Thomas wrote:
> While building ANT 1.2.1, got the following error:
> C:\Jakarta\jakarta-ant\build.xml:87: Cannot use classic compiler, as
> it is not
> available

I had this problem as well. I tried following all the FAQ suggestions
and nothing worked. My JAVA_HOME was set, tools.jar was in the
classpath, I tried messing with ant.bat, I looked at the source code for None of those worked.

What finally worked for me was to put tools.jar into the extension
directory. With Java 2 (either jdk 1.2 or jdk 1.3) you no longer need to
put libraries on the classpath. If you put the .jar file into a special
directory, then the compiler and JVM pick up the libraries
automatically. If your java.exe is in %JAVA_HOME%\bin then the extension
directory is %JAVA_HOME%\jre\lib\ext. 

Kevin Mukhar

View raw message