ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David.Bai...@lawson.com
Subject jdk1.2.2, jdk1.3 and jaxp.jar
Date Fri, 08 Dec 2000 18:30:22 GMT



I'm trying to compare ant1.2 running with jdk1.2.2 to ant1.2 running with
jdk1.3.

After a bit of fuddling around, I successfully installed ant with jdk1.3,
created some build.xml
files, and ran a build.  I now wish to use jdk1.2.2 instead.

Realizing that I will need to rebootstrap and rebuild ant using the jdk1.2.2
compiler, I removed ant,
then re-opened the jakarta-ant-src.tar file and tried to run bootstrap.sh again
(after resetting $JAVA_HOME
and so forth).

The build now fails because ant claims it is unable to locate a JAXP-compliant
XML parser.  I
investigated a bit and discovered the jaxp.jar file which is delivered in the
lib directory of ant.  I
edited the bootstrap.sh file to make it echo the CLASSPATH at the appropriate
time, and sure enough,
that jaxp.jar is the third item in the CLASSPATH, after "classes" and
"src/main".

The only explanations I can come up with for the error are the following:

     1) A version of jaxp.jar was delivered which was compiled with jdk1.3, and
          therefore is not jdk1.2.2 compatible, or
     2) I have inadvertently left some jdk1.3-compiled classes lying around
which
          are interfering with the build.  But I find that difficult to believe
since I
          performed an 'rm -rf ant' and 'rm -rf build', changed to the jdk1.2.2,
then
          tried to rebuild ant.

I also checked to make sure there aren't any rogue ant.jar files anywhere.

Any ideas?

--dave



Mime
View raw message