ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David.Bai...@lawson.com
Subject Installing ant on Solaris 5.7
Date Tue, 05 Dec 2000 23:01:22 GMT


Howdy.

I installed ANT on an NT 4.0 server, and everything went fine.  I'm now
attempting to install it on a Solaris 5.7 box, but when I run bootstrap.sh, I
get the warnings:

     chmod: WARNING: can't access bin/ant
     chmod: WARNING: can't access bin/antRun

Upon closer inspection, I find that I can't access these files because the bin
directory doesn't exist.  I have copied the bin directory and its contents from
my NT 4.0 box via FTP (all end-of-line characters have been cleaned up), and
that allows the bootstrap.sh to complete.  But then build.sh runs into a problem
the first time it actually attempts to invoke ANT, with the message

     ... Done Bootstrapping Ant Distribution
     Exception in thread "main" java.lang.NoClassDefFoundError:
org/apache/tools/ant/Main

I believe the reason for this error is that the org.apache.tools.ant class does
not exist.  The ant.jar is not in the lib directory.  I tried to solve this by
copying
the ant.jar file from by NT box, but then I ran into another problem I couldn't
solve and by then I figured I had done enough hacking.

I have defined $JAVA_HOME and $ANT_HOME.  Any ideas about what's going wrong?

--dave



Mime
View raw message