ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Marr <listser...@gmx.net>
Subject Re: Please help - "Cannot use classic compiler"
Date Wed, 20 Dec 2000 15:34:36 GMT


> > While building ANT 1.2.1, got the following error:
>
> BUILD FAILED
>
> C:\Jakarta\jakarta-ant\build.xml:87: Cannot use classic compiler, as it is
> not
> available
>
> Any suggestions on what could be done to fix this? I am using JDK 1.3.
> --
> Thanks in advance
> Jacob

JDK 1.3 is the "modern" compiler .
So if you don't have 1.1 or 1.2 on your System and try to use the classic 
compiler, it should fail.

Use this in your Build-File:

<!-- modern = JDK 1.3 ; classic = JDK 1.1/1.2 ; jikes = Jikes-->
<property name="build.compiler" value="modern" />

-- 
Michael

Mime
View raw message