ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Carlson <jcarl...@is.com>
Subject RE: path separators and properties
Date Mon, 06 Nov 2000 19:51:41 GMT
I think I answered my own question.  I switched to double backslashes in my
properties file and then ant keeps it as a backslash.


-----Original Message-----
From: Jonathan Carlson [mailto:jcarlson@is.com]
Sent: Monday, November 06, 2000 10:53 AM
To: 'ant-user@jakarta.apache.org'
Subject: RE: path separators and properties


I forgot to mention that the issue seems to be in the copy command.
Sometimes we want the filter to use forward slashes, and sometimes we want
the filter to use backslashes.  
 
Someone else must have run into this before.  Thanks in advance for any
answers or brainstorms!  :-)
 
Jonathan
 
-----Original Message-----
From: Jonathan Carlson 
Sent: Monday, November 06, 2000 10:47 AM
To: 'ant-user@jakarta.apache.org'
Subject: path separators and properties


I'm kind of stuck with an issue of path separators (I love to hate microsoft
;-).  I understandably have to use forward slashes when I put an absolute
file or directory into a properties file.  But if I then use that same
property file in a filtersfile argument to create a DOS batch file, the
slash comes out with a forward slash, which DOS complains about big time.
 
Does anyone know how I can have this both ways?
 
Thanks!
 
Jonathan
 
 
Jonathan Carlson
Minneapolis, Minnesota

Mime
View raw message