ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Kessel <Chris.Kes...@merant.com>
Subject Ant on Solaris: modern/classic compiler not available
Date Wed, 15 Nov 2000 17:14:59 GMT
I'm having a devil of a time getting Ant to work for me on Solaris.  I've
got ant working on an NT box, and I want to move the system to my Solaris
box (where I really do most of my work edit/compile cycle).

I've got jdk1.3 in my path.  "which javac" shows it's there.  When I run ant
though it complains that "modern compiler is not available - using classic
compiler", and then "Cannot use classic compiler, as it is not available."

I'm going bonkers here. I can go the directories and type a "javac foo.java"
just fine, but for whatever reason ant can't seem to find/run javac.

Any help would be great.  I'm not on the mailing list as of yet, so please
include my email address in the response.

Thanks,
Chris
chris.kessel@merant.com

Mime
View raw message