ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jeremie hebre" <jeremie.he...@corp.vizzavi.net>
Subject Re: problem with VSSGET
Date Mon, 27 Nov 2000 15:40:13 GMT
My path names doesn't contain any space. Moreover, they are environment variables.
My script, including the values of my ${} :

<vssget login="deploy,deploy"
            localPath="../src"
            recursive="true"
            vsspath="/dev/deployer/src"
            writable="false"/>

  ----- Original Message ----- 
  From: KC Baltz 
  To: 'ant-user@jakarta.apache.org' 
  Sent: Monday, November 27, 2000 2:04 PM
  Subject: RE: problem with VSSGET


  I just dealt with this issue.  Look at http://marc.theaimsgroup.com/?l=ant-dev&w=2&r=1&s=vss&q=b
to see the recent conversation.  For me, it boiled down to an issue of path names with spaces
in them.  When I replaced the names with their ~'ed equivalents (e.g. C:\Program Files ==
C:\progra~1) it worked fine.  I also use / instead of \, not sure if that was part of the
fix or not.  If that doesn't help, include the values of your ${} properties so we can get
a better idea of what you're doing.

   
  K.C. Baltz
  Senior Engineer
  Response Networks, Inc.
  North Andover, MA
  (978)725-3133
    

   
   -----Original Message-----
  From: jeremie hebre [mailto:jeremie.hebre@corp.vizzavi.net]
  Sent: Monday, November 27, 2000 5:56 AM
  To: ant-user@jakarta.apache.org
  Subject: problem with VSSGET


    Hi,

    I'm trying to use vssget task. When using the command line, I manage to get the files
from VSS. But when using the following task:

    <vssget login="${vss.user},${vss.password}"
                localPath="${src.dir}"
                recursive="true"
                vsspath="/dev/${project.deploy}/src"
                writable="false"/>


    , I get the following error message:


    Buildfile: build.xml

    getsources:

    BUILD FAILED

    C:\dev\deployer\build\build.xml:143: java.io.IOException: CreateProcess: ss Get $/dev/sample/src
-
    GLC:\dev\deployer\src -I- -R -Ydeploy,deploy  error=2
    java.io.IOException: CreateProcess: ss Get $/dev/sample/src -GLC:\dev\deployer\src -I-
-R -Ydeploy
    ,deploy  error=2
            at java.lang.Win32Process.create(Native Method)
            at java.lang.Win32Process.<init>(Win32Process.java:64)
            at java.lang.Runtime.execInternal(Native Method)
            at java.lang.Runtime.exec(Runtime.java:272)
            at org.apache.tools.ant.taskdefs.Execute$CommandLauncher.exec(Execute.java:325)
            at org.apache.tools.ant.taskdefs.Execute$CommandLauncherProxy.exec(Execute.java:431)
            at org.apache.tools.ant.taskdefs.Execute$WinNTCommandLauncher.exec(Execute.java:456)
            at org.apache.tools.ant.taskdefs.Execute.execute(Execute.java:247)
            at org.apache.tools.ant.taskdefs.optional.vss.MSVSS.run(MSVSS.java:161)
            at org.apache.tools.ant.taskdefs.optional.vss.MSVSSGET.execute(MSVSSGET.java:167)
            at org.apache.tools.ant.Target.execute(Target.java, Compiled Code)
            at org.apache.tools.ant.Project.runTarget(Project.java:818)
            at org.apache.tools.ant.Project.executeTarget(Project.java, Compiled Code)
            at org.apache.tools.ant.Project.executeTargets(Project.java, Compiled Code)
            at org.apache.tools.ant.Main.runBuild(Main.java, Compiled Code)
            at org.apache.tools.ant.Main.main(Main.java:149)

    Total time: 0 seconds
    Press any key to continue . . .


    Any ideas?

    Jérémie

Mime
View raw message