ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@m64.com>
Subject RE: wlrun task java 1.3 -server option
Date Sat, 11 Nov 2000 01:58:45 GMT
Cyril,

Can you run ant with the -debug flag to see what the command line is
used to run the server when you specify -server in the jvmargs?

Conor


> -----Original Message-----
> From: cyril@wyvern.hotwirebiz.com
> [mailto:cyril@wyvern.hotwirebiz.com]On
> Behalf Of Cyril Bouteille
> Sent: Saturday, 11 November 2000 6:13
> To: ant-user@jakarta.apache.org
> Subject: wlrun task java 1.3 -server option
>
>
> Hi,
>
> When I use the following task in ant:
>     <wlrun home="${wl.home}"
>            classpath="${wl.boot.cp}"
>            wlclasspath="${java.class.path}"
>            properties="weblogic.properties"
> 	   jvmargs="${wl.args}"/>
>
> It fails if the -server (or -client) option of JDK 1.3 is set in the
> jvmargs:
> weblogic:
> Copying 1 files to /home/cyril/p4/hotwire/2.0/deploy/dev/weblogic
> Unrecognized option: -server
> Could not create the Java virtual machine.
> BUILD FAILED
>
> I'm pretty sure weblogic starts with JDK 1.3 since, when I remove the
> option, the log reports:
> Fri Nov 10 10:54:12 PST 2000:<I> <System Props> java.home =
> /home/cyril/p4/java/sunos-sparc/1.3/jre
> Fri Nov 10 10:54:12 PST 2000:<I> <System Props> java.runtime.name =
> Java(TM) 2 Runtime Environment, Standard Edition
> Fri Nov 10 10:54:12 PST 2000:<I> <System Props> java.runtime.version =
> 1.3.0
>
> I can start weblogic with -server just fine with the regular
> startWebLogic.sh script.
>
> Any idea why this option is not supported by <wlrun>?
>
> Thanks,


Mime
View raw message