ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy XueWen Qin <a...@cisco.com>
Subject a possible bug in Exec ?
Date Thu, 12 Oct 2000 17:33:47 GMT
I'm trying to use exec task on Windows NT, it's very simple
test build.xml file, but giving out a strange error. When I
change the dir="." to dir="..", it works fine, any ideas ?
The ant version I'm using is Ant1.1.
-----------
build.xml
------------
<?xml version="1.0" ?>
<project name="test" default="dist" basedir=".">
  <target name="dist" >
    <exec dir="." command="dir" os="Windows NT" output="dir.txt" />
  </target>
</project>
------------
error message:
-----------
build.xml:4: Error exec: dir
java.io.IOException: CreateProcess: dir error=2
        at java.lang.Win32Process.<init>(Compiled Code)
        at java.lang.Runtime.exec(Compiled Code)
        at java.lang.Runtime.exec(Runtime.java:137)
        at org.apache.tools.ant.taskdefs.Exec.run(Exec.java:124)
        at org.apache.tools.ant.taskdefs.Exec.execute(Exec.java:77)
        at org.apache.tools.ant.Target.execute(Compiled Code)
        at org.apache.tools.ant.Project.runTarget(Project.java:717)
        at org.apache.tools.ant.Project.executeTarget(Compiled Code)
        at org.apache.tools.ant.Project.executeTargets(Compiled Code)
        at org.apache.tools.ant.Main.runBuild(Compiled Code)
        at org.apache.tools.ant.Main.main(Main.java:107)

Total time: 0 seconds
------------------------

Thanks
/andy


Mime
View raw message