ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Conor MacNeill" <co...@ebinteractive.com.au>
Subject RE: jdk1.2.2 javac debug attribute
Date Wed, 04 Oct 2000 22:23:42 GMT
Ross,

Not really an ant issue. This is due to the use of JIT in JDK 1.2.2 and not
about the debug attribute of javac.

You can try setting the environment variable, JAVA_COMPILER, like so.

set JAVA_COMPILER=NONE

(adjust the above for your favourite operating system)

This will turn off the JIT and restore line numbers for you in the
stacktraces.

Cheers
Conor

--
Conor MacNeill
conor@cortexebusiness.com.au
Cortex eBusiness
http://www.cortexebusiness.com.au

> -----Original Message-----
> From: rossg@shiva.golder.org [mailto:rossg@shiva.golder.org]On Behalf Of
> Ross Golder
> Sent: Thursday, 5 October 2000 8:09
> To: ant-user@jakarta.apache.org
> Subject: jdk1.2.2 javac debug attribute
>
>
> I have the following in my build.xml, but my stacktraces are not giving
> line numbers (just says 'Compiled code' in their place). :
>
>     <property name="debug" value="on"/>
>
> ...
>
>     <javac srcdir="${src.dir}"
>            destdir="${build.dest}"
>            debug="${debug}"
>            optimize="${optimize}"/>
>
> Fairly recent ant. Worked fine under JDK1.1.8, but not since upgrading
> to JDK1.2.2.
>
> [rossg@durban cybertrax]$ java org.apache.tools.ant.Main -version
> Ant version 1.1 compiled on July 21 2000
>
> Any ideas why?
>
> --
> Ross
>
> Apathy on the rise, nobody cares!
>


Mime
View raw message