ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott M Stark" <Scott_St...@displayscape.com>
Subject Re: echo message does not translate properties
Date Fri, 20 Oct 2000 21:19:44 GMT
In what context and with what version of ant do you see this behavior? Using
1.2rc1 I am able to echo the properties defined within a target.

bash-2.04$ ant -version
Ant version 1.2rc1 compiled on October 14 2000
bash-2.04$ cat tst.xml
<?xml version="1.0" encoding="UTF-8"?>

<project name="JavaSerializationTests" default="run" basedir="./">

        <target name="run">
                <property name="version" value="V0" />
                <echo message="in run, version = ${version}" />
                <antcall target="runV">
                        <param name="version" value="${version}" />
                </antcall>
        </target>

        <target name="runV">
                <echo message="in runV, version = ${version}" />
        </target>

</project>
bash-2.04$ ant -buildfile tst.xml
Buildfile: ..\tst.xml

run:
in run, version = V0

runV:
in runV, version = V0

BUILD SUCCESSFUL

Total time: 0 seconds

----- Original Message ----- 
From: "Christopher Elkins" <celkins@scardini.com>
To: <ant-user@jakarta.apache.org>
Sent: Friday, October 20, 2000 1:33 PM
Subject: Re: echo message does not translate properties


> > I would like to echo back the value of properties to a user but the
> > following
> > <property name="aprop" value="abc" />
> > <echo message="aprop = ${aprop}" />
> > 
> > results in
> > 
> > aprop = ${aprop}
> > 
> > 
> > when I would like it to result in
> > 
> > aprop = abc
> > 
> 
> Was this ever addressed? I don't see anything in the archives.
> 
> --
> Christopher Elkins
> 
> 


Mime
View raw message