ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erik Meade" <eme...@geekfarm.org>
Subject Problem with deltree in my build.xml
Date Mon, 25 Sep 2000 23:16:10 GMT
The deltree tasks in this snippet of my build.xml are not being executed.

  <!--
=================================================================== -->
  <!-- Run
         -->
  <!--
=================================================================== -->
  <target name="runtests" depends="compiletests" if="junit.present">
    <copydir src="${src.tests.dir}"
             dest=".">
       <exclude name="*.java" />
       <include name="**/*.java" />
     </copydir>

    <junit printsummary="no" fork="yes" haltonfailure="no">
      <classpath>
        <pathelement location="${build.classes}" />
        <pathelement location="/java/cvs/jakarta-ant/lib/ant.jar" />
        <pathelement location="/java/junit/junit3.2/junit.jar" />
        <pathelement location="${build.tests}" />
        <path refid="classpath" />
      </classpath>

      <formatter type="plain" usefile="false" />

      <test name="MeasureTest" />
      <test name="AbstractnessVisitorTest" />
      <test name="AbstractnessTest" />
      <test name="StabilityVisitorTest" />
      <test name="StabilityTest" />
    </junit>

    <deltree dir="AbstractnessTestCase"/>
    <deltree dir="StabilityTestCase"/>

  </target>

I did a test to make sure deltree works the way I think it does:

<?xml version="1.0"?>

<project name="AntTest" default="test" basedir=".">
  <target name="test">
    <copydir src="testdir/"
             dest=".">
      <include name="**/*.txt"/>
    </copydir>
    <deltree dir="copydir"/>
  </target>
</project>

This works, can anyone see what I am doing wrong above?

Thanks!

Erik Meade


Mime
View raw message