ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian D. Wisniewski" <>
Subject RE: ant and Win98 (Newbie Question)
Date Thu, 07 Sep 2000 13:59:04 GMT
Good Morning,

Changing the line-feeds did help with clearing up the bad command or file
name issue.

Now however, I get the following when I attempt to run ant:

Error: could not open `C:\Program Files\JavaSoft\JRE\1.3\lib\jvm.cfg'

This does not seem to make sense because the JRE\1.3\lib folder does not
exist within Javasoft?

I am running Win98 with Ant v1.1, jdk1.2.1, Java API for XML Parsing v1.0.1,
and Java 2 Runtime Environment Standard Edition v1.3.

My Path is set to the following:

My CLASSPATH is set to:

I have also set the following:
SET JAVA_HOME=c:\jdk1.2.1
SET JAXPHOME=C:\Program Files\JavaSoft\Jaxp1.0.1

I suspect I'm missing something obvious but can't put my finger on it.

Any information or guidance would be greatly appreciated.


Brian D. Wisniewski

-----Original Message-----
From: Ralf Purnhagen []
Sent: Thursday, September 07, 2000 2:12 AM
Subject: Re: ant and Win98

Mike Pedersen wrote:
> Hello, I've been using ant with much success over the last couple months
> NT Solaris and Linux.  I have recently tried to run it on win98 with no
> success.  I have set ant_home, java_home and the ant/bin directory is in
> the path.  I have also changed all references to "program files" in the
> and.bat to point to short directory names thinking that there might be a
> problem with long file names.  When ever I attempt to run "ant" I get bad
> command or file name.  Any thoughts on this would be much appreciated.

Maybe your .bat-Files still have unix-style line feeds. DOS (or the
command line cannot process such files correctly. Try to open the
with windows notepad. If there are unix-style line feeds in the file,
there will be black boxes instead of line-feeds.


View raw message