ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From oliver.bo...@rwg.de
Subject Antwort: RE: Antwort: RE: ejbjar task [Virus checked]
Date Wed, 20 Sep 2000 12:52:40 GMT

Am 20.09.2000 12:28:17 schrieb manomohan_k:
> Hi
> Could the problem be a typo :-)
> See comment below.
> MM= Manomohan>
> Cheers
> Mano

Ups, thank you. Now this message disappears, but I got the old one :-(Error
from ejbc..., see below).

...
> > >
> > >     ERROR: Error from ejbc: The JNDI name of bean AGOEditor was not set
> > >
> > > It seems the weblocgic-ejb-jar.xml file is missing in the input
> > > jar file for
> > > the EJB compiler, but why?
> > > Here's my target which I copied from the documentation:
> > >
> > >   <target name="weblogic.ejb" depends="compile.server">
> > >     <ejbjar srcdir="${build.classes.server}"
> > >             descriptordir="${descriptor.dir}">
> > >       <weblogic destdir="${deploymentjars.dir}"/>
> > >       <include name="**/*-ejb-jar.xml"/>
> > >       <exclude name="**/*weblogic*.xml"/>
> > >     </ejbjar>
> > >   </target>
> > >
> > > When I do the EJB compile manually it works so the XML and class
> > > files are ok.
> > > Any hints what I made wrong?
> >
> > Not really.
> >
> > What you have pretty much matches what I have. The only different being
> > that
> > I use a classpath attribute on the <weblogic> element. This classpath
> > contains all the weblogic classes, and the classes from, in your case,
> > ${build.classes.server}.
>
> ok, I added now a classpath attribute:
>
>   <target name="weblogic.ejb" depends="compile.server">
>     <ejbjar srcdir="${build.classes.server}"
>             descriptordir="${descriptor.dir}">
>       <weblogic destdir="${deploymentjars.dir}"
>                 classspath="${classpath.weblogic}:${build.classes.server}"
>       />
>       <include name="**/*-ejb-jar.xml"/>
>       <exclude name="**/*weblogic*.xml"/>
>     </ejbjar>
>   </target>
>
> but when I try it, I got the message "BUILD FAILED":
>
>   build.xml:199: Class
> org.apache.tools.ant.taskdefs.optional.ejb.WeblogicDeploymentTool doesn't
> support the "classspath" attribute
>
> Which version of ant are you using? I have
> "Ant version 1.2alpha2 compiled on September 18 2000"
>
> MM> Did you mean classpath="${classpat..." and not
> classspath="${classpat.... in line 5 of the target element?
>
> >
> > The only other thing I can think of would be the name of the
> > weblogic-ejb-jar.xml relative to the ejb-jar.xml file. Can you give us
> the
> > full names of both these files?
>
> They are both placed in the same directory.
>
> >
> > Cheers
> > Conor
>
> Cheers
> Oliver
Mime
View raw message