ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Francis <brett.fran...@mediagate.com>
Subject Re: Random Classes not being Compiled
Date Mon, 07 Aug 2000 20:19:04 GMT
We found out our problem.

In the BATCH file that we were using to launch Ant we had an erroneous
CLASSPATH. This CLASSPATH had classes in it that were being discovered from
another directory and accepted as existing when another target was being
created.

We've resolved it by removing this reference from the CLASSPATH and now
everything works.

Peter Donald wrote:

> The only thing I noticed is that the "source" property is not set (at least
> that I can see) and so when you use it in
>
>         <javac srcdir="${source}"
>             destdir="${accessor.build}"
>             classpath="${accessor.classpath}"
>             includes="com/mediagate/adapter/**,com/mediagate/tools/**"
>             debug="on"/>
>
> you may confuse the task. Try defineing source and make sure it is a
> directory but you don't include the / at the end. If that doesn't work post
> again :P
>
> Cheers,
>
> Pete
>
> *------------------------------------------------------*
> | "Nearly all men can stand adversity, but if you want |
> | to test a man's character, give him power."          |
> |       -Abraham Lincoln                               |
> *------------------------------------------------------*

--
_________________________________________
|> Brett Francis
|> mediagate, inc.
|> mailto:brett@mediagate.com



Mime
View raw message