ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 61649] The same scripted invocation of Ant works on z/OS using 1.9.7, but fails using 1.9.9
Date Wed, 25 Oct 2017 08:36:21 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=61649

--- Comment #8 from cpisapia@ie.ibm.com ---
Hi,

We copied the Ant 1.9.6 ant script from that GitHub link and tried it on z/OS
and it worked.

A couple of additional clarifications:
* I've run a few more tests (have run many of these over the last while and it
gets confusing) and for me to get this to work with Ant 1.9.6 or Ant 1.9.7 on
z/OS I have to use the -Dwsadmin.extra.args value with escaped quotes; e.g.:
-Dwsadmin.extra.args=\"-javaoption -Xmx1024m -appendtrace true\"  The
significance of this is that I'm pretty sure I didn't always have to escape the
double quotes on the command line; however, I retested with Ant 1.9.9 to
confirm that even escaping the double quotes doesn't fix it.
*  I reported I saw the same issue on RHEL with Ant 1.9.9 using
-Dwsadmin.extra.args. I retested this on RHEL with the Ant 1.9.6 script (and
1.9.7) and it works if I escape the double quotes and fails if I do not.  It
fails in either case with 1.9.9.  the issue seems to be with outliers and Red
Hat seems fairly mainstream.
I don't know when/why this changed.

Thanks

-- 
You are receiving this mail because:
You are the assignee for the bug.
Mime
View raw message