ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nicolas Lalevée (JIRA) <j...@apache.org>
Subject [jira] [Resolved] (IVY-1418) Missing Import-Package line in MANIFEST.MF: org.w3c.dom
Date Sun, 24 Sep 2017 14:05:00 GMT

     [ https://issues.apache.org/jira/browse/IVY-1418?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Nicolas Lalevée resolved IVY-1418.
----------------------------------
       Resolution: Fixed
         Assignee: Nicolas Lalevée
    Fix Version/s: 2.4.0

indeed
cf https://github.com/apache/ant-ivy/commit/d7b7c8a84583937deddc1ab88c54f46ca70cfdcd#diff-0c844a45c5473fde04630bb296ace0f2

> Missing Import-Package line in MANIFEST.MF: org.w3c.dom
> -------------------------------------------------------
>
>                 Key: IVY-1418
>                 URL: https://issues.apache.org/jira/browse/IVY-1418
>             Project: Ivy
>          Issue Type: Bug
>         Environment: Apache Felix 4.2.0 OSGI Container
>            Reporter: Orsolya Mebold
>            Assignee: Nicolas Lalevée
>             Fix For: 2.4.0
>
>
> After installing the ivy bundle (2.3.0) the following runtime exception occurs when using
@Grab(...) construct in a groovy script:
> org.w3c.dom.Document not found by org.apache.ivy [134]
> Adding the org.w3c.dom to the 'Import-Package' section of the MANIFEST.MF file solves
the issue and @Grab works as expected.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message