ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From j..@apache.org
Subject [1/3] ant-ivy git commit: Use Java 7 as the minimum required Java version
Date Mon, 29 May 2017 12:57:25 GMT
Repository: ant-ivy
Updated Branches:
  refs/heads/master 6e906cc8e -> 5601c44f6


Use Java 7 as the minimum required Java version


Project: http://git-wip-us.apache.org/repos/asf/ant-ivy/repo
Commit: http://git-wip-us.apache.org/repos/asf/ant-ivy/commit/04d7c699
Tree: http://git-wip-us.apache.org/repos/asf/ant-ivy/tree/04d7c699
Diff: http://git-wip-us.apache.org/repos/asf/ant-ivy/diff/04d7c699

Branch: refs/heads/master
Commit: 04d7c6991de41612a287ef12504d347be7942fe2
Parents: 24b5e00
Author: Jaikiran Pai <jaikiran.pai@gmail.com>
Authored: Mon May 29 16:52:32 2017 +0530
Committer: Jaikiran Pai <jaikiran.pai@gmail.com>
Committed: Mon May 29 16:59:42 2017 +0530

----------------------------------------------------------------------
 META-INF/MANIFEST.MF   | 2 +-
 build.properties       | 2 +-
 doc/compatibility.html | 6 ++++--
 3 files changed, 6 insertions(+), 4 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/ant-ivy/blob/04d7c699/META-INF/MANIFEST.MF
----------------------------------------------------------------------
diff --git a/META-INF/MANIFEST.MF b/META-INF/MANIFEST.MF
index c4986fc..cb8e757 100644
--- a/META-INF/MANIFEST.MF
+++ b/META-INF/MANIFEST.MF
@@ -109,4 +109,4 @@ Export-Package: org.apache.ivy;version="2.0.0",
  org.apache.ivy.util.filter;version="2.0.0",
  org.apache.ivy.util.url;version="2.0.0"
 Bundle-ClassPath: .
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
+Bundle-RequiredExecutionEnvironment: J2SE-1.7

http://git-wip-us.apache.org/repos/asf/ant-ivy/blob/04d7c699/build.properties
----------------------------------------------------------------------
diff --git a/build.properties b/build.properties
index cc08112..5b28e22 100644
--- a/build.properties
+++ b/build.properties
@@ -42,7 +42,7 @@ checkstyle.report.dir=${reports.dir}/checkstyle
 checkstyle.src.dir=${basedir}/src/etc/checkstyle
 rat.report.dir=${reports.dir}/rat
 
-ivy.minimum.javaversion=1.5
+ivy.minimum.javaversion=1.7
 debug.mode=on
 ivy.install.version=1.4.1
 

http://git-wip-us.apache.org/repos/asf/ant-ivy/blob/04d7c699/doc/compatibility.html
----------------------------------------------------------------------
diff --git a/doc/compatibility.html b/doc/compatibility.html
index a298558..65a0244 100644
--- a/doc/compatibility.html
+++ b/doc/compatibility.html
@@ -29,11 +29,13 @@
 
 Up to Ivy 2.3.x, a minimum of Java 1.4 is required.
 
-Since Ivy 2.4.0, a minimum of Java 5 is required.
+For Ivy 2.4.0, a minimum of Java 5 is required.
+
+Since Ivy 2.5.0, a minimum of Java 7 is required.
 
 <h1>Apache Ant</h1>
 
-Ivy doesn't require much of Ant and should run correctly on pretty old versions. But it is
recommended to use at least Ant 1.6.
+Ivy doesn't require a specific version of Ant as long as the Ant being used complies with
the JVM compatibility requirements noted above.
 
 <h1>Other optional dependencies</h1>
 


Mime
View raw message