ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 60679] New: Missing messages while debugging Ant build file using Eclipse IDE
Date Thu, 02 Feb 2017 09:55:38 GMT
https://bz.apache.org/bugzilla/show_bug.cgi?id=60679

            Bug ID: 60679
           Summary: Missing messages while debugging Ant build file using
                    Eclipse IDE
           Product: Ant
           Version: 1.10.0
          Hardware: PC
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Core
          Assignee: notifications@ant.apache.org
          Reporter: sarika.sinha@in.ibm.com
  Target Milestone: ---

<project name="debugAntCall"
         default="default">

        <target name="default">
                <antcall target="call">
                </antcall>
                <echo>default</echo>
        </target>

        <target name="call" depends="pre-call">
                <echo>call1</echo>
                <sleep milliseconds="30" />
        </target>

        <target name="pre-call">
                <echo>pre-call1</echo>
        </target>
</project>

While debugging Ant build file in a separate JRE, and putting a debug point at
"pre-call" target, there is a missing item in the stack. We don't get "call" in
the stack trace.
Working stack trace message in 1.9.8:
message:
suspendedbreakpoint,C:\Eclipse\Workspace\runtime-New_configurationAnt198\Test\debugAntCall.xml,4
message:
stack,default,,C:\Eclipse\Workspace\runtime-New_configurationAnt198\Test\debugAntCall.xml,4,
message:
suspendedbreakpoint,C:\Eclipse\Workspace\runtime-New_configurationAnt198\Test\debugAntCall.xml,15
message:
stack,pre-call,,C:\Eclipse\Workspace\runtime-New_configurationAnt198\Test\debugAntCall.xml,15,call,,C:\Eclipse\Workspace\runtime-New_configurationAnt198\Test\debugAntCall.xml,10,default,antcall,C:\Eclipse\Workspace\runtime-New_configurationAnt198\Test\debugAntCall.xml,5,

Missing message for the intermediate "call" stack trace -
message:
suspendedbreakpoint,C:\Eclipse\Workspace\runtime-New_configuration_Ant1_10\Test\debugAntCall.xml,4
message:
stack,default,,C:\Eclipse\Workspace\runtime-New_configuration_Ant1_10\Test\debugAntCall.xml,4
message:
suspendedbreakpoint,C:\Eclipse\Workspace\runtime-New_configuration_Ant1_10\Test\debugAntCall.xml,15
message:
stack,pre-call,,C:\Eclipse\Workspace\runtime-New_configuration_Ant1_10\Test\build.xml,15,default,antcall,C:

\Eclipse\Workspace\runtime-New_configuration_Ant1_10\Test\debugAntCall.xml,15

When I profiled using Yourkit and compared the 1.9.8 and 1.10.0 stacktrace,
Antlib.createAntlib(Project project, URL antlibUrl, 
                                      String uri)
is missing in the 1.10.0 stack trace. And I see the code 
 try {
            URLConnection conn = antlibUrl.openConnection();
            conn.setUseCaches(false);
            conn.connect();
        } catch (IOException ex) {
            throw new BuildException(
                "Unable to find " + antlibUrl, ex);
        }
So looks like something is going wrong here.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Mime
View raw message