ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reşat SABIQ (JIRA) <j...@apache.org>
Subject [jira] [Commented] (IVY-1553) PGP signing during publication shouldn't require bouncy castle dependencies to be in .ant/lib or forking another java process with classpath explicitly configured to contain bouncy castle modules
Date Tue, 13 Dec 2016 03:27:58 GMT

    [ https://issues.apache.org/jira/browse/IVY-1553?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15744016#comment-15744016
] 

Reşat SABIQ commented on IVY-1553:
----------------------------------

FYI: I'm using ivy 2.4.0, & i've got the same results using bouncy castle 1.49 and 1.50
(1.51+ isn't compatible w/ ivy 2.4.0). Apparently, the root cause appears to be in classloading:
a parent classloader ends up being used, which isn't aware of the classes available in a child
classloader.

P.S. I believe the issue is also present in trunk since no commits since 2.4.0 appear to contain
a potential fix for this issue.

> PGP signing during publication shouldn't require bouncy castle dependencies to be in
.ant/lib or forking another java process with classpath explicitly configured to contain bouncy
castle modules
> ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: IVY-1553
>                 URL: https://issues.apache.org/jira/browse/IVY-1553
>             Project: Ivy
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.4.0
>            Reporter: Reşat SABIQ
>              Labels: pgp
>
> With
> 		<signers>
> 			<pgp name="default-sig" keyId="${pgp.key}" password="${pgp.password}"/> 
> 		</signers>
> in ivysettings.xml,
> ivy kept throwing CNFE until i put these dependencies in .ant/lib:
> 		<dependency org="org.bouncycastle" name="bcpg-jdk15on" rev="1.49" conf="default"/>
> 		<dependency org="org.bouncycastle" name="bcprov-jdk15on" rev="1.49" conf="default"/>
> I ended up putting the following comment in ivy.xml:
> 		<!-- First 2 currently must be in .ant/lib (pgp signer didn't work via dependency
or ivycache manipulation, etc). -->
> P.S. I believe this issue is ongoing since 2012/13.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message