ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (EASYANT-76) Eclipse project classpath is broken
Date Tue, 09 Aug 2016 06:40:20 GMT

    [ https://issues.apache.org/jira/browse/EASYANT-76?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15413034#comment-15413034
] 

ASF GitHub Bot commented on EASYANT-76:
---------------------------------------

GitHub user AQuillet opened a pull request:

    https://github.com/apache/ant-easyant-core/pull/2

    Upgrade Junit: fix Eclipse project classpath

    https://issues.apache.org/jira/browse/EASYANT-76

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/AQuillet/ant-easyant-core feature/EASYANT-76

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/ant-easyant-core/pull/2.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #2
    
----
commit 276111f2ffa53e340f1b6a37eda2136ed2128a02
Author: Adrien Quillet <adrien.quillet@microej.com>
Date:   2016-08-09T06:31:49Z

    Upgrade Junit: fix Eclipse project classpath
    https://issues.apache.org/jira/browse/EASYANT-76

----


> Eclipse project classpath is broken
> -----------------------------------
>
>                 Key: EASYANT-76
>                 URL: https://issues.apache.org/jira/browse/EASYANT-76
>             Project: EasyAnt
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 0.10
>            Reporter: Adrien Quillet
>            Priority: Trivial
>              Labels: easyant, eclipse, integration, patch
>         Attachments: Upgrade-JUnit-fix-Eclipse-project-classpath.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> Since Junit upgrade (https://github.com/apache/ant-easyant-core/commit/e1417410a8d75a3e94b1533a84700408396a445e),
EasyAnt Core project classpath is broken in Eclipse.
> {{.classpath}} file still references Junit 4.11, but Junit 4.12 is use. 
> There are multiple solutions to this issue:
> * Update {{.classpath}} file to point to Junit 4.12
> * Remove revision in retrieved pattern to avoid this kind of issue
> Here is a patch to fix Junit revision in {{.classpath}} file.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message