ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Kratz (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (IVY-1481) NPE in p2 repo resolver
Date Sun, 03 Aug 2014 06:10:11 GMT

    [ https://issues.apache.org/jira/browse/IVY-1481?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14083880#comment-14083880
] 

Thomas Kratz edited comment on IVY-1481 at 8/3/14 6:09 AM:
-----------------------------------------------------------

Look at line 1887 in the attached file. Theres a variant of require that causes the error.


was (Author: eiswind):
Look at line 1887 in the attached file. Theres a variant of match that causes the error.

> NPE in p2 repo resolver
> -----------------------
>
>                 Key: IVY-1481
>                 URL: https://issues.apache.org/jira/browse/IVY-1481
>             Project: Ivy
>          Issue Type: Bug
>          Components: Core
>    Affects Versions: 2.4.0-RC1
>         Environment: Windows, Ant 1.9.4
>            Reporter: Thomas Kratz
>            Priority: Minor
>         Attachments: content.xml, ivy-p2.patch
>
>
> When I try to load _any_ artifact from
> http://download.eclipse.org/rt/rap/2.3/
> I get 		
> :: bundle#org.eclipse.osgi;3.10+: java.lang.NullPointerException at org.apache.ivy.osgi.p2.P2MetadataParser.namespace2Type(P2MetadataParser.java:338)
> (with 2.3.0, 2.4 RC1 simply says NPE ocurred)
> I can only guess that there is some namespace in the repo not correct.



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message