ant-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject [Bug 56337] New: Extension point target rewriting
Date Tue, 01 Apr 2014 19:33:35 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=56337

            Bug ID: 56337
           Summary: Extension point target rewriting
           Product: Ant
           Version: 1.9.3
          Hardware: PC
            Status: NEW
          Severity: regression
          Priority: P2
         Component: Core
          Assignee: notifications@ant.apache.org
          Reporter: rich@steelezone.net

Created attachment 31464
  --> https://issues.apache.org/bugzilla/attachment.cgi?id=31464&action=edit
Sample build scripts

I have two build files, the main one called build.xml:

<project name="build">
    <import file="hello.xml" />
    <target name="hi">
        <echo message="Hello" />
    </target>
</project>

and hello.xml that it imports:

<project name="hello">
    <extension-point name="greeting" />
    <target name="hi" extensionOf="greeting">
        <echo message="Hi!!!" />
    </target>
</project>

With Ant 1.8.4 when I run the "greeting" target I get:

λ ant greeting
Buildfile: C:\Development\projects\ant-playground\override-target\build.xml

hi:
     [echo] Hello

greeting:

BUILD SUCCESSFUL
Total time: 0 seconds

However, with Ant 1.9.3 I get:

λ ant greeting
Buildfile: C:\Development\projects\ant-playground\override-target\build.xml

hello.hi:
     [echo] Hi!!!

greeting:

BUILD SUCCESSFUL

This change in behavior is obviously wrecking havoc with our build scripts that
depend on some amount of target overriding.  Is the new behavior considered the
correct way and, if so, is there a way to revert back to the old behavior?

I suspect this is related to bug 54940.

-- 
You are receiving this mail because:
You are the assignee for the bug.
Mime
View raw message